Solved

Azure DevOps integrated cards are all greyed out for editing


Badge +1

Hi, I’ve got a board with a bunch of ADO linked cards that has been working great but today when I’ve logged into Lucid to try and edit the cards the edit fields are all greyed out.  I can open the cards in ADO from Lucid and make the updates in ADO which do sync back but I can’t seem to make any edits in Lucid directly.  It was all working find last week.  I’ve tried disconnecting and reconnecting my Microsoft account but the problem persists.  Any idea’s what the problem might be? 

icon

Best answer by Shantel Gillette 8 July 2024, 21:04

View original

Comments

Userlevel 3
Badge +4

Good morning! 

Is it possible that your document has been switched from Lucidspark to Lucidchart (using our fast product switching feature), and this is causing the issue with not being able to edit the cards? 

Badge +1

Hi Shantel, thanks for the response.  I’ve tried switching between spark and chart but I see the same problem in both, edit is all greyed out. 

Userlevel 3
Badge +4

Popping in here to update you. I don’t have an answer yet, but I’m working to see if anyone knows what is happening. We made some changes recently that might be impacting you, but we are confirming first. Thank you for being patient! I will let you know as soon as I have more information, and resolution.

Userlevel 3
Badge +4

Ok after some digging, it’s not likely that this is being caused by any changes Lucid has made recently (but I’m not ruling that out completely yet).

It sounds like Microsoft has a unique way of authenticating accounts and this could be the cause here, possibly your Microsoft has mistakenly been auto-provisioned with another Microsoft account. To rule that out, we would suggest the following: Completely log out of Microsoft accounts, clear cache and cookies, go through the ADO auth again. I’m hoping this resolves the issue. Can you let me know if that works?

Badge +1

Hi Shantel, sorry for the delayed response.  I’ve been of ill for a few days.  I think I’ve done everything you’ve suggested above.  I unlinked my Microsoft integration from Lucid. Deleted the Lucid authorisation from my ADO account.  Cleared my Chrome browser history.  Logged back into Lucid and launched my board again.  Added a new ADO card.  Card added fine and appeared in ADO but when I try to edit this new card, or any of the old linked ones, they are still greyed out in Lucid and can only be edited directly in ADO.  Is there a step I’ve missed or got wrong?  

Userlevel 3
Badge +4

Good afternoon,

Thank you for trying those steps. It’s unfortunate that they didn’t resolve the issue. One possibility is that you are still somehow connected to two (or more) Azure instances. You can check that by going to your Account Settings (by clicking on your user icon in the upper right hand corner of the home page), then to the left clicking on “Apps and Integrations”, and then under Azure you should see how many connected instances there are. 

 

Another suggestion was to completely uninstall the integration from the Marketplace page. You can do this by going to Integrations> Click the Lucidspark tab> Find Lucid Cards for Azure DevOps (or just do a search)> Click the listing> Click “Disconnect” in the top right of the listing. It’s part of my corporate account so I can’t disconnect mine, but the images below should give you an idea of what to do.

 


Let me know if that works! 

Reply