Solved

Shapes Disappearing in PNG export


Shapes are disappearing when I export to PNG with transparent background (300 dpi). How do I ensure the shapes export?


 


icon

Best answer by Sami H 18 March 2022, 21:06

View original

Comments

Badge

Dear Amelia, I found it, many thanks for your support! Best regards, Simone

Userlevel 4
Badge +6

Hi @Simone, no problem! Happy to help! The text block shape would work, but the shape that came to mind is just called “Rectangle” and is the generic “Shapes” shape library. If needed, you can add text to this shape by double clicking, but it will be blank by default. If this library is not appearing in your Shapes Panel, you can browse and add more Shape Libraries by following the steps outlined in our Help Center article. Let me know if you have any further questions!

 

Badge

 

Badge

Dear Amelia, oh, I can see what you mean. Many thanks for your analysis! As I don’t need the links/hotspot, what do you mean by “Rectangle shape”? Is it the a simple “text block” (see pink circle in the picture underneath) under “Standard”?

Everything else is displayed correctly when doing an export.

Userlevel 4
Badge +6

Hi @Simone, thanks for sharing that PIN! After taking a look on my end, I was able to see that the grey shapes were not exporting as you described. However, it looks like these are Hotspot shapes, as listed in the Shapes In Use section of the Shapes panel. You can add links to any shape, so I would recommend changing those shapes to the Rectangle shape, then adding any links to those rectangles. From what I could see, it looked like all other shapes were exported as expected, but were you seeing other shapes missing on your end?

Badge

Hello Amelia, here you go, thank you very much! EG3WS9MsW4dr

Userlevel 4
Badge +6

Hi @Simone, thanks for letting me know! Yes, you can post your PIN here, as other users will not be able to access your documents with it, as I also use our internal system with the PIN to take a closer look.

Badge

Hi dear @Amelia W, thank you for your answer! No, it’s not a hotspot shape. Can I post my support PIN here (is it visible for anyone)?

Userlevel 4
Badge +6

Hi @Simone, thanks for adding to this thread! One thing to check, are the shapes you are using Hotspot shapes? When exporting, publishing, or presenting a diagram that contains a hotspot, the hotspot shape will disappear. For more information on adding Links to objects in your diagram, you can reference this Article from the Lucid Help Center, as you will need to use actions to have you links function in an exported document.

If this is not the case, can you please send a temporary Support PIN for this document? This will allow me to take a closer look at the issue you’re experiencing. For more information on generating a Support PIN, check out this Help Center article. I appreciate your help and patience!

Badge

Hi everyone, I tried with different browsers and I don’t have any groups, but neverthess, my coloured shapes don’t appear on any of the supported exports. Could you please take a closer look to this, @Lucid support team? Thank you!

Userlevel 5
Badge +14

Hi Iven! Glad you were able to resolve the issue - please let us know if you have any additional questions.

@liam o Thank you so much you just saved me a huge headache.

Userlevel 6
Badge +17

@liam o Thanks so much for sharing your troubleshooting tip with everyone! 

In case it helps anyone I was running into this issue when I had shapes 'grouped' together.  When I ungrouped them and then exported the resulting image looked as I expected.

Hello Chad 

Thank you for continuing on this thread! Can you try exporting from different browsers and see if the problem persists. If that doesn't work try toggling WebGL off. This can be done by going to View > Rendering > Use WebGL and un-selecting this option. If none of these options work please post in our Product Feedback section and we will take a closer look at this issue you are experiencing. 

Any update on this one? I'm having the same problem. I tried Incognito I'm on a fiber optic network and it is NOT a master page.  I get an image however it's just missing most of the shapes and includes only background layers.

 

Hi Jeff 

Thanks for posting in the Lucid Community! 

Just to make sure that we are on the same page please review our Export Your Lucidchart Documents article from the Lucidchart Help Center. Let me know if you have any questions about how downloading/exporting your document should work.

Once you have reviewed this article here are some specific things to check when exporting your document:

  • Try the export in a Chrome Incognito browsing session. This often improves performance by clearing your cache and cookies and disabling your extensions.
  • Sometimes issues like this can be related to internet connection speed or network security. Please try the export again on another network ensuring that you are on a strong stable connection.
  • Is the page that you are trying to export a Master Page? If so it will be omitted from the downloaded version of your document and you will need to convert it into a page before exporting. To do this left-click on your Master Page tab and select "Convert to Page".

If none of these tips help please let me know so we can get you the appropriate help!

Reply