Error 500 when trying to upload new custom shape package

  • 27 October 2023
  • 3 replies


I'm working on a custom shape library. I got a new package uploaded but there was a problem with it. So I fixed it (I think) and tried to upload a new bundle and I got an error:
Can't seem to figure out what the issue is.


Userlevel 3
Badge +7

Hi Christopher

Thank you for reaching out to us and for providing the error details. I apologize for the inconvenience you're experiencing while trying to upload a new version of your custom shape library.

I've checked our logs and couldn't find any 500 internal server errors associated with your UserID in the past 24 hours. This suggests that the issue might be localized to your browser or network environment.

Let's get to the bottom of the issue. As a first step please try these troubleshooting steps:


  • Clear browser cache.
  • Try again from a private or incognito browser window.
  • Try a different network if possible.
  • Ensure that the .zip file you're trying to upload is not corrupted. You might want to re-zip your files and try uploading the new .zip file.

If you've tried all these steps and are still experiencing issues please reply with a screenshot of your JavaScript console errors after re-attempting the upload.

Thank you for your patience and cooperation. We look forward to resolving this issue for you.

Tried all of those things including pairing to my phone as a second network. I had the npx bundle recreated nothing did the trick:

Userlevel 3
Badge +7

Thank you for trying that and getting back to us. I opened a support ticket so we can take a closer look at your file and get this resolved!