Solved

The width of the first column of a table is determined by the longest word in a merged row


Badge +1

Hello,

I like using tables in my charts. I’ve noticed a very annoying characteristic. The minimum width of any column seems to be the maximum word width in any of the rows within that column. Empty column widths can be extremely narrow, like this:

But once you start typing in that column, it will automatically expand to accommodate the largest word:

Notice, I cannot reduce the width of that first column any more. This is not too big of a deal, as it’s nice to be able to read the contents of a cell.

The problem occurs when several columns are merged within a row. When that happens, the width of the first column in that merged set is now determined by the longest word anywhere within the merged section. It prevents having a narrow first column, which would be very common for having numbered rows, for example:

There’s no way to reduce the width of the column that contains the numbers because the width is determined by the width of the word “Hippopotamus” in the “title” merged section. This wastes so much space.

Is there any way to fix this issue?

Sincerely,

Marcus

icon

Best answer by Kelsey Gaag 31 May 2024, 17:48

View original

Comments

Userlevel 5
Badge +9

Hi @ILikeTables

Thank you for posting in the Lucid Community! If you click on a table you should see a contextual panel on the right side of the document. At the bottom of the panel, there is an option to disable Auto Resizing. This will stop the table from adjusting to the text. 

 

Badge +1

Oh wow, so simple. Thank you!

Userlevel 5
Badge +9

@ILikeTables Of course! Please let me know if you have any other questions or concerns😊

Reply